WEB相談室

Webページ作成に関しての何でも掲示板です。

タイトル:vinelinixヘのPHPインストール

0:[投稿] おか [2003/05/06 12:35 ][環境:unix.apache.postgresql unix.apache.postgresql]

PHPとpostgresqlを使ってフォームで入力したデータをデータベースにいれようと考えています。apacheとpostgresqlは既にインストールされてます。PHPを(php-4.2.3-0vl1.i386.rpm)ダウンロードしてインストールしようとしましたが下記のようなエラーが返されます.
エラー:依存性の欠如
       libexpat.so.0php-4.2.3-0vl1はphp-4.2.3-0vl1に必要とされています
       libsablot.so.0はphp-4.2.3-0vl1に必要とされています
       libxml2.so,2はphp-4.2.3-0vl1に必要とされています
       libxslt.so.1はphp-4.2.3-0vl1に必要とされています
       libxsltbreakpoint.so.1はphp-4.2.3-0vl1に必要とされています

なにをインストールすればいいか教えていただけませんか?


1:[回答] ひよこ [URL] [2003/05/07 18:10 ]

詳しくはわかりませんが、DSOモジュールが無いのかもしれません。
以下参考
http://httpd.apache.org/docs-2.1/ja/dso.html
(ちなみに細かなインストール方法や注意事項などは他の識者の方宜しく)


2:[回答] ふじ [URL] [2003/05/07 21:13 ]

Vine なら apt を使ってインストールすれば、依存関係のあるパッケージも
一緒にインストールしてくれると思いますが。

http://vinelinux.org/manuals/using_rpm.html


3:[完了] おか [2003/05/08 03:29 ]

解答ありがとうございます。aptを使えばいっしょにできるんですか? 勉強になりました。結局vineのホームページに行き似たような名前のrpmをインストールしたら問題無く動きました。知識不足だったようです。

回答(必須): 状態:

お名前(必須):

e-mail:

URL:




[戻る]

ChaichanPAPA's World