WEB相談室

Webページ作成に関しての何でも掲示板です。

タイトル:NNだと表示されない?

0:[投稿] mine [MAIL] [URL] [2002/07/17 23:13 ][環境:WIN+IE わからない]

当サイトのトップページにて、背景画像URLをスタイルシートで指定していますが、
Netscape Communicator4.78では表示されません。
(ちなみに、HTMLの<BODY>タグにはBGCOLOR=whiteを指定しています。)
以下にソースを書きます。
これのほかにも、MacのIE(?)だとトップページのHTMLがメチャクチャになる、とか、
ネスケだと入ってすぐのページ上部フレームの画像に施したJavaScriptが途中で動かなくなる、など、いろいろ問題を抱えております。
バグ(?)なんでしょうか?どなたかお教えいただけないでしょうか?

=ソースここから==========================================
<STYLE type="text/css">
<!--
  BODY{
     background-image: url(opening.gif);
     background-repeat: no-repeat;
     background-position: right bottom;
     background-attachment: scroll;
     color:#666666;
     font-family:'MS ゴシック';
     font-size: 9pt; }
  -->
 </STYLE>
=ソースここまで========================================


1:[回答] さっぱり★ [2002/07/18 10:58 ]

とりあえず、
<META HTTP-EQUIV="content-type" CONTENT="text/html;CHARSET=Shift_JIS">
に直しておきましょう。(4行目を消して3行目にこれを挿入)


2:[回答] やじうま1号 [2002/07/18 17:12 ]

http://www6.plala.or.jp/go_west/css2/ref/list.htm

CSSの実装状況は上のページでとりあえずわかりますかね。 CSS2ですが。


3:[質問] mine [MAIL] [URL] [2002/07/18 21:06 ]

さっぱり★様、やじうま1号様、ご回答ありがとうございます。
お教えいただいた上のサイトは、とても勉強になりました。
CSSって、ブラウザによって実装状況がかなり違うんですね・・・。

それと、最初の質問でも触れたんですが、
入り口から入ってすぐのページの上部フレームに施した
JavaScriptが、Netscapeだとうまく動作しないという問題を抱えております。
まったく動作しないとか、エラーが出るとかなら、構文ミスかなぁと思うんですが、
初めのうちは動いてるのに途中からまったく機能しなくなるので、
何がいけないのかさっぱりわかりません。

具体的に言いますと、アイコン画像にマウスカーソルが乗ったときに画像を入れ替えるのと、画像の下に隠してある<TABLE>を表示させる、
というJavaScriptを施してあります。
それが、Netscapeだと、初め2〜3回は画像入れ替え・<TABLE>表示とも動作するのに、それ以降まったく反応しなくなります。
(WinのIE5.0ではまったく問題なく動いています。)

もともとJavaScriptの知識があまりなく、文献の見よう見まねで記述してるのが悪いとは思うのですが・・・。
もしよろしければ、何が悪いのか、見てやっていただけないでしょうか。
よろしくお願いします。
上の[URL]に直接、問題のフレームのあるページにリンクをしておきました。

回答(必須): 状態:

お名前(必須):

e-mail:

URL:




[戻る]

ChaichanPAPA's World